Update: 4:33 AM - 1 Sep 2016:
EA games & services are available. Support wait times may still be impacted. For 1x1 assistance, please contact us. (via @AskEASupport)
EA is currently experiencing an outage. EA games, services & support may be impacted. We’re working to resolve as fast as possible. (via @Battlefield)
Created by Red Spider
Trademarks are the property of their respective owners. Game materials copyright Electronic Arts Inc.
Electronic Arts has not endorsed and is not responsible for this site or its content.